Home > Minecraft Mods > SpaceCore Mod for Minecraft 1.7.10

SpaceCore Mod for Minecraft 1.7.10

The SpaceCore Mod is a necessary support for Minecraft players who are using Spacechase0’s mods. They are designed to operate with key files from SpaceCore. So if you want to use any of these mods, you will surely need to install this. This may due to the fact that they are all made by the same author.    

SpaceCore Mod

Some typical mods are Component Equipment, Useful Pets, Survival Wings, Text Formatting, and Biome Wand Mod, etc.

If you don’t use any mod that requires SpaceCore, then, there is no need to pick up this mod. You are not going to get anything from it.

In fact, there are many master mods like this one containing files that other mods need to function. So next time, you just need to skip the whole review then download it.

SpaceCore Mod for Minecraft 1.7.10 Changelogs

  • Fixed “Format error: …” in mods using TranslateUtils.
  • Removed in-game config GUI (crashed on mods screen and LunatriusCore).
  • Fixed crash in TranslateUtils.

Download Links for SpaceCore Mod

for Minecraft 1.7.10 – Requires Forge API

Credit: spacechase0

Leave a Reply

Your email address will not be published. Required fields are marked *